Page 1 of 1

Error Searching on Comic: FF '01

Posted: Fri Jul 16, 2010 12:07 pm
by MentalMinutiae
Having trouble in the "Go to Comic" search field for Fantastic Four (Vol. 3) Annual 2001.

It's listed/shown under some of the individual character names (Invisible Woman, Mister Fantastic) as FF '01, but when I type that in the "Go to Comic" field I get the following error message:

"Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '01' ORDER BY appendix,figid,entry_index' at line 1"

Is there a correct entry to locate this comic or is this a broken link?

I've also tried other variations (FF3 '01, FF '2001, FF3 '2001, etc) to no avail...


Re: Error Searching on Comic: FF '01

Posted: Fri Jul 16, 2010 2:19 pm
by Russ Chappell
The Search function is outside of my control, but I'll try to contact Jimmy over it. I'm guessing that MySQL is interpreting the apostrophe as an open quote. I've tried & gotten the same results for other books that had these sorts of annuals.

Here's a clunky workaround:

Take someone that we know is in FF '01, like Mr. Fantastic. He appears in FF '01 immediately after FF3 46. Search for FF3 46. Mr. Fantastic is listed there, with FF '01 as his previous appearance. Click on FF '01, and get a listing of everyone else in that issue. This method does require knowing at least one character who appears in the book in question, that the book not be the only book the character appears in, and that the character appears in some book other than just annuals with years as their number. That shouldn't be a problem, since you'd expect at least an appearance from the character the annual is named after.

We'll look into it.

Re: Error Searching on Comic: FF '01

Posted: Fri Jul 16, 2010 5:16 pm
by MentalMinutiae
Thanks a lot - forgot about the links to next / previous appearances! So that trick worked just fine for me - will remember in the future if I come across something like this again.

Re: Error Searching on Comic: FF '01

Posted: Sat Jul 17, 2010 7:41 am
by Somebody
Also, you can precede the ' with a backslash (so search for FF \'01 in this case) and that'll work. [Like Russ said, it's interpreting the ' as an open quote, so the PHP escape character \ makes it treat the ' as an apostophe]